home page

Results 1 to 3 of 3

Thread: 4D Hasp error message - Need Help!!!!

  1. #1
    Join Date
    Sep 2010
    Rep Power

    Unhappy 4D Hasp error message - Need Help!!!!

    I have the 4D Viking Embroidery Program. When I tried to open the program on Sunday afternoon, I got the error message: "Unable to access Hasp SRM Run-time Environment (H0033)". I researched it on Google and tried those suggestions with none solving the problem. I tried putting the program disk in the computer and doing a repair but that resulted in a 2nd and 3rd shortcut on the desktop and hasp still will not work. I have Dell Vista, which I love, and am now thinking maybe a Windows update may have caused the problem. I know enough about computers to get myself in trouble.

    Has anyone had this problem and how did you solve it? Need help ASAP before my helpful loving husband takes it apart. Thanks Barb

  2. #2
    Join Date
    Dec 2007
    Rep Power


    I also had this problem a few months ago with my new 5D Extra program. I was told to find a list of allowed programs in Norton and allow full access to 5D Embroidery and Sentinel Hasp (which is actually named something else in my computer). After spending on-line time with HV support, they decided that my antiviral program was somehow causing the interference and they suggested I contact Norton for resolution. I probably should have but didn't because I was soooooo upset at the time with technical support. Instead, I called the local computer repair who was able to give me some tips over the phone but not immediately resolve the problem. I wished I could remember how to find that setting again to help you. Anyway, eventually it worked itself out and I haven't had problems since.

    Here is a part of the e-mail from HV that I received. Maybe it will be helpful to you and your DH:

    The Unable to access HASP SRM Run-time environment (H0033) error, will occur when the software used to facilitate communication between your Aladdin HASP (dongle) and your 4D Embroidery software is blocked by your security software. The most common form of security software capable of blocking the program and communication for the Aladdin HASP is called a firewall.

    A firewall is a dedicated software program or hardware appliance, which inspects network traffic passing through it, and denies or permits passage based on a set of rules. This means the communication program our software and dongle use may be actively blocked by a security program running on your computer unless otherwise told to allow the program to run.

    The Embroidery System 8.1 and later uses new features that are only found in the HASP SRM driver (dongle driver). The Hasp License Manager Service (C:\Windows\System32\hasplms.exe) components of these drivers are needed to update your dongle to use the features of the HASP SRM drivers and to allow the 4D Embroidery software to open. These features increase the security of the program itself and add value to your 4D purchase.

    Some security software, usually the firewall component, may try to block the hasplms.exe file from fully accessing the dongle components of your computer.

    During the 4D Embroidery System 8.1 install, most security software will give you the option to 'Allow' or 'Deny' the hasplms.exe file the access that it needs. If the security software or firewall does not receive a response it often will automatically deny the traffic and Hasplms.exe from running.

    First do the following to make sure that the HASP License Manager Service is started:

    1. Click the Start button.

    2. Right Click on Computer.

    3 . Click on Manage.

    4. In Computer Management go to Services and Applications

    5. Open Services.

    6. Locate the Hasp License Manager and double click on it to to open it.

    7. Click on the Start button if the service status is Stopped.

    If the Service Status is started or will not start, you must know what security software/ firewall you have installed to your computer.

    You may have purchased the software as a package or it may have come with a new computer so you may not have much paperwork and support information to help you locate the product and its configuration on your computer.
    Last edited by la_cole; June 22nd, 2011 at 01:08 PM.
    Never give up, never surrender.

  3. #3
    Join Date
    Sep 2010
    Rep Power

    Default 4D Hasp error message - Need Help!!!

    I am not a computer expert but know enough to really get myself in to TROUBLE. I had the program for several years and it has worked without any problems but apparently an update or computer burp happened and the program ceased to work. At the time I also had 3D and it also did not work but I was able to get it going. I have a 1501 Inspiron Dell Vista computer and tried all of the suggested fixes except to re-install Vista and none of them worked for me. I even removed and re-installed the 4D program, several times, and it still did not work. I purchased a 5D program and installed it. At first I had problems with the hasp drivers and then it all of a sudden worked. I have not worked with the 4D program since because I have the 5D program working. Thanks for your help.

    Quote Originally Posted by Anthony View Post
    What windows are you using because this problem is create mostly in windows XP service pack2 sp i just recommend you to reinstall your windows and i prefer to install Microsoft windows 7 this is giid and latest features of windows and you can found all the new latest features in tihs windows anyways i was also suffered from this problem and refresh to my computer after reinstall the windows 7....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts